Login   ·   Register   ·   Account help   ·   Privacy policy   ·   Contact

Game crash when trying to fire  

« Previous | Pages 1 | Next »

Forum Index » X Universe » Roguey's X3 Mod » General


 avatar
Chamkey Level badge

Posted 5 years ago.
I had this mod before when I was using windows 7 x86 and it worked perfectly.
I just recently upgraded to windows 7 x64 and the mod is now crashing the game.
The game is also updated to v2.5

I've played with the mod disabled and no problems occurred as soon as I enable the mod the first thing I notice is that there is no text under the window on the top left of the screen there isn't a border either.
The moment I try to fire my guns the game crashes.
Another problem I've noticed is that when I go into the story mode the game crashes right at the beginning.

Please help me roguey.

Other information:
I have not used any other mods on the game because I think yours is awesome XD.
4gb RAM
Core i5 650
GTS 450 1GB

 avatar
Roguey Level badge

Posted 5 years ago.
hi there,

when you said you were using win7 x86, did you mean win7 32bit?

I also use win x64 myself. So I just tried the mod and it seem to work okay (X3 v2.5a - steam version). You said it crashes when starting story mode (which start?). Would there be any chance you could provide a save just before it crashes, so I could try it (and see what happens)?

usually things like this happen if the mod has gotten corrupted, or a file is missing.

 avatar
Chamkey Level badge

Posted 5 years ago.
It's the start that has Julian training cadets. I've checked it out on a number of different starts and they all have the same problem. Every time I try to fire the game crashes. Unfortunately I can't save the game before it crashes (Julian start)
 avatar
Roguey Level badge

Posted 5 years ago.
That is very strange, as when I checked it last night it was fine. I just checked with the downloaded version (ie. get it from the net) and it was still okay:

Picture

So, I gather at this point it would crash for you? That was on the normal start position. Maybe retry re-downloading the mod encase it had a problem (as it sounds like a missing file or something).

 avatar
Chamkey Level badge

Posted 5 years ago.
could it be that the problem was that I installed it using archive mode instead of using plugin install or is that not supposed to be a problem anyway...?

I am re-downloading the mod anyway just to check.

And no that isn't the point... You're looking down at your ship as it flies toward another ship to receive orders... As it flies away and get's smaller, just before it changes to the other ship and the guy starts speaking, the game crashes...

 avatar
Chamkey Level badge

Posted 5 years ago.
I re-downloaded the mod and followed the instructions in the readme very carefully this time. Finally got the message that says X3 mod installed when I started the mission and voila it works. No more crashing.

Thanks for the help roguey.

 avatar
Roguey Level badge

Posted 5 years ago.
Ah glad to hear its working okay. I guess the re-downloaded fixed the problem?
 avatar
Chamkey Level badge

Posted 5 years ago.
I seriously don't know.

The size of the rar files were exactly the same down to the last byte. I honestly think the reason for it crashing was that I used the x-universe plugin manager to install it whereas when I installed it now, I copied the files over to the X3 folder instead.

 avatar
Roguey Level badge

Posted 5 years ago.
Oh, that will be the reason for the problems. as the mod was designed to be installed without any extra programs or tools.
You need to log-in to post here.
Please log-in, then refresh this page.

« Previous | Pages 1 | Next »